Unable to log in into our Chrome Extension
Incident Report for Overloop
Resolved
Our Chrome Extension is now fully working since version 3.25.3.

We apologize for the inconvenience and thank you for your patience.

Happy prospecting with Overloop!
Posted Oct 21, 2021 - 18:27 CEST
Update
Users are now able to log in into our Chrome Extension using a version above 3.25.2.
We observed an infinite search issue though. A new version is on its way to fix this issue.
Posted Oct 21, 2021 - 17:55 CEST
Identified
Users are currently unable to log in into our Chrome Extension. A new version is on its way and is waiting for Google approval.
Posted Oct 21, 2021 - 14:16 CEST
This incident affected: Extension.